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Converting user dictionaries from earlier versions of PageMaker
and from other applications

The Dictionary Editor lets you continue to work with user dictionaries from
earlier versions of PageMaker. It also lets you reuse user dictionaries created in
another software application, if that application stores its user dictionary file in
text-only format (for example, PageMaker 3.x), or if it can open and then save the
file in text-only format (for example, Microsoft Word).

To convert a user dictionary created with PageMaker 4.0 or 4.01, simply open a
copy of the file using the ‘‘Open—’’ command in the Dictionary Editor.  Be
aware, however, that once you open the file in the Dictionary Editor, you cannot
use that user dictionary in PageMaker 4.0 or 4.01. For this reason we suggest you
make a backup copy of the user dictionary file before you convert it.

To work with dictionaries from other applications, including PageMaker 3.x, you
import the user dictionary file into a new or existing file in the Dictionary Editor.
PageMaker 3.x saves it user dictionary files in text-only format. The PageMaker
3.x user dictionary is named ‘‘pmususer.txt.’’  In Microsoft Word, the default user
dictionary is named ‘‘User 1.’’ You must open the file from within Microsoft
Word, and then save it in text-only format before you can import it into the Dic-
tionary Editor. For more information on user dictionaries in other programs, refer
to the documentation that came with the software.

Remember that while the Dictionary Editor uses tildes to indicate hyphenation
breaks, user dictionary files from other programs may indicate hyphenation
breaks with hyphens rather than with tildes, or may not include hyphenation
breaks at all.

If the text-only file uses hyphens rather than tildes, follow these steps: First,
import the file into the PageMaker story editor, and then use the ‘‘Change—’’
command on the Edit menu to replace all the hyphens with tildes. Next, export
the file in text-only format, and then import that file into the Dictionary Editor.
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Note: When you add words the dictionary, be sure to type the word exactly as you
want it to be spelled and capitalized in your publications. For more information on
capitalization, see the ‘‘Spelling—’’ command description in the Aldus PageMaker
Reference Manual.

Importing a word list
Once the word list is saved as a text-only file, open the user dictionary into which
you want to add the words, and then choose ‘‘Import—’’ from the File menu to open
the ‘‘Import text document’’ dialog box.

Hyphenate on import using algorithm: Hyphenates the words according to the built-in
algorithm. (The Dictionary Editor does not apply the algorithm to words in which
you’ve already added tildes.)

Import words already in dictionary: Overwrites words that are already in the user diction-
ary with words that have the same spelling. If this option is unchecked, any words
in your list that are already in the user dictionary will not be overwritten.

Typing a word
To type a new word, click in the ‘‘Word’’ edit box, and type the word exactly as you
want it to be spelled and capitalized in your publications. When you finish typing,
click ‘‘Add’’ or press Return to add the word to the dictionary.
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Hyphenating words

In the Dictionary Editor, you can specify that words be hyphenated according to a
built-in algorithm, according to your own ranked hyphenation settings, or not at
all.

· To use the built-in algorithm, select the word in the list box, and choose
‘‘Hyphenate’’ from the Edit menu.

· To define your own hyphenation breaks, double-click the word you want to
modify and, in the ‘‘Word’’ edit box, type a tilde (~) at each point where you
would permit hyphenation. You can rank hyphenation breaks by typing from
one to three tildes, where one indicates the most preferable break and three
tildes indicates the least preferable break.

· To prevent a word from being hyphenated, simply leave the word unhyphen-
ated.

Use tildes to indicate hyphenation preferences.

Note: Once you have created a user dictionary, use the settings in the PageMaker
‘‘Hyphenation’’ dialog box to determine the way text in your publication will be
hyphenated. For example, you can specify that hyphenation be turned on or off,
which type of hyphenation you will allow (manual, dictionary, or algorithm), and
so on. For more information about the ‘‘Hyphenation—’’ command, refer to the
Aldus PageMaker Reference Manual.

Adding words

The Dictionary Editor lets you add words to a user dictionary by importing a list
of words from a text-only file, or by adding words one at a time by typing each
word individually. This section describes these two techniques.

To add a large number of words at one time, create a word list with PageMaker or
with any program that creates or exports text-only files. In the list, separate each
word by a carriage return, space, or tab. You can also indicate any special hyphen-
ation preferences by adding tildes to words in the list before you import the file.

Tip:
As an alternative to typing a tilde, you
can press the Option key and click an
insertion point where you want to
insert a hyphenation break.
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Selecting and editing words

You modify an existing word by scrolling down the list and double-clicking it, so
that the word appears in the ‘‘Word’’ edit box. You can then make spelling or
hyphenation changes in the edit box. To delete a word, select the word in the list
box and click ‘‘Remove.’’

To save your changes, click ‘‘Replace’’ or press Return. To remove the word from
the edit box without making the changes permanent, click ‘‘Cancel’’ or press
Escape (Esc).

Finding words

To find a word in the list without scrolling to search for it, choose ‘‘Find—’’ from
the Edit menu, type the word in the ‘‘Find what’’ edit box, and then select your
search criteria.

Whole word: Limits the search to entire words.

Match upper/lowercase: Limits the search to words that are capitalized exactly as you
typed them in the ‘‘Find what’’ edit box.

To begin the search, press Return, or click ‘‘Find.’’ When the Dictionary Editor
finds a match, the word is selected in the list box. To locate the next occurrence of
the text, click the ‘‘Find next’’ button.
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The Dictionary Editor displays a separate window for each dictionary you open.
You can have a maximum of five dictionaries open simultaneously. Within each
dictionary window, words appear in alphabetical order. Tildes (~) indicate ranked
hyphenation breaks--one tilde indicates the most preferable break, and three
tildes indicate the least preferable hyphenation break. The ‘‘Language’’ option
specifies the language that the currently selected dictionary uses.

Note: The Dictionary Editor cannot open a user dictionary that contains over
15,000 words. However, you can add as many words as you like using PageMaker
(choose ‘‘Hyphenation—’’ from the Type menu in layout view or ‘‘Spelling—’’
from the File menu in story view, and then click ‘‘Add—’’). For more information
on modifying user dictionaries from within PageMaker, refer to the Aldus
PageMaker Reference Manual.

Working with files

The Dictionary Editor File menu contains commands for working with dictionary
files--you can use them to open new or existing files, save and rename user
dictionaries, quit the program, and so on. This section briefly describes the
commands on the File menu.

New—: Creates a new, empty user dictionary. When you name the file, the
filename extension ‘‘.udc’’ is added automatically. If you don’t type a name, the
dictionary is named ‘‘Untitled.’’ After creating a new file, be sure to install it in the
correct language folder.

Open—: Opens an existing user dictionary.

Close: Closes the current user dictionary window.

Save: Saves changes to the current user dictionary.

Save as—: Lets you change the name or location of the dictionary.

Import—: Lets you import a text-only file consisting of a list of words separated by
carriage returns, tabs, or spaces. For more information on importing words, see
‘‘Adding words’’ later in this article.

Export—: Creates a text-only file consisting of the words in the current user diction-
ary. In the text file, each word occupies a single line followed by a carriage return,
and tildes indicate hyphenation points.

Install—: Moves the current user dictionary to the appropriate language folder so
that PageMaker can use it to spell-check and hyphenate words.

Note: You can have only one user dictionary installed for each language at any
one time. If you install a user dictionary for a language that already has one, the
Dictionary Editor prompts you to move the currently installed user dictionary for
that language to a different folder. If you are modifying a user dictionary that has
already been installed, you do not have to re-install it.

Print—: Prints the dictionary. The name of the dictionary file appears on the top of
each printed page.

Quit—: Exits the program and, if necessary, prompts you to save changes.

Important:
If you install a user dictionary for one
language into a folder for a different
language dictionary for which no user
dictionary exists, PageMaker will not
recognize the user dictionary, and will
overwrite it with a new user dictionary.
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Understanding PageMaker dictionaries

PageMaker 4.2 uses Proximity 6.0 dictionaries to check spelling and to hyphenate
words. PageMaker supports up to 16 installed hyphenation and spelling dictionar-
ies. The dictionaries are stored in the Proximity folder within the Aldus folder on
your hard drive. Each language dictionary you choose to install is stored in its own
folder, with its associated files, within the Proximity folder.

Each language dictionary comes with a user dictionary--a separate file that
supplements the base-language dictionary, and contains all of the words you add
during spelling checks or during your work with the Dictionary Editor. You can
recognize the user dictionary file for each language by its ‘‘.udc’’ filename exten-
sion. For example, ‘‘AldEng.udc’’ is the user dictionary file associated with the
U.S. English language dictionary.

To check spelling and hyphenate words with a user dictionary, you must make
sure that the user dictionary file is installed (that is, stored) in the corresponding
language folder. You can install a user dictionary either by using the Dictionary
Editor ‘‘Install—’’ command (described later in this article), or by dragging a user
dictionary file to the correct folder and then restarting PageMaker.

Note: The user dictionaries you create with the Dictionary Editor are not compat-
ible with PageMaker 4.0 or 4.01.

Working with the Dictionary Editor

The Dictionary Editor is installed in the Utilities folder. To start the program,
double-click its icon in that folder.

The Dictionary Editor window

Important:
Although you can create two or more
user dictionaries for any one language
(for example, to contain terminology for
specific technical areas), you can have
only one user dictionary installed at one
time for each language. If you create a
second user dictionary for a particular
language, be sure to move the existing
user dictionary to another folder in order
to use the new one.

The Dictionary Editor icon
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Using the Dictionary Editor

PageMaker 4.2 gives you a new tool for controlling spell-checking and hyphen-
ation in your publications-- the Dictionary Editor. The Dictionary Editor is a
standalone utility that lets you create or modify PageMaker user dictionaries. It
cannot be used to edit the Proximity language dictionaries. This article describes
how you can use the Dictionary Editor to:

· work with user dictionary files --opening, saving, installing, printing, and so
on.

· select and edit words.

· find words quickly.

· change the way words are hyphenated.

· import or type new words into a user dictionary.

· convert dictionaries created in an earlier version of PageMaker or created in
other applications.


